Need some technical genius (game crashes)

When I installed Absolver and tried to launch it I got a black screen and the game exited itself, then I got some error about vcredist 2012 after I got the error I deleted and reinstalled all vcredists (2005,2008,2010,2012,2013,2015), I redownloaded the game, checked the game files, tried to run as admin, set launch options to -sw -window and none of those things worked but now I dont get any error when I try to launch the game it goes into the loading screen and I get a windows crash where windows is looking for a solution ( it doesnt find one) and I'm forced to press close program

Anyone got any similar problems or know any ideas to help me, please?


  • Hi MisterWh1t3,

    We're sorry to hear you're having trouble launching the game! Could you give us more details, such as:
    - Your set up (which version of Windows are you running, computer specs...)
    - Any screenshots showing the error
    - Do you have similar issues with other games?
    Also, make sure your Windows is all up to date, including video drivers, and you've reinstalled the latest version of Visual C++. Thank you!
Sign In or Register to comment.