EAC Kicked: Authentication timed out (1/2)

Hello. I am a fresh prospect, but my quest was suddenly interrupted.

After the free trial ended, I bought the game on sale. When I tried to jump back to fight, after a couple of minutes spent in the loading screen I was kicked back to the menu, with the message (included in the screenshot : https://imgur.com/MpIjXVp ) :

"EAC Kicked: Authentication timed out (1/2)

Checking/fixing my local files onj Steam didn't help. Neither reinstalation did.

And on top of that, another bug appeared. When I tried to continue once again, game immadietly closed, and i following message was displayed: ( https://imgur.com/2yRu8RS )
[Translation of the message from polish: Unknown version of the file: (file path)]

I request for help from Absolvers and their overseers. It seems that the game holds great potential, but I am unable to fight for now.
Please let me know if i can prrovide any more usefull information.
Thank you in advance.


  • Whoopsie posted in wrong category. Gonna flag for deletion and repost in proper one.
  • Hey IΔI,

    Thanks for reaching us with your concerns about launching the game.

    You have placed your post in the correct category, so another duplicate will be deleted. It doesn't sound like a bug right now, but it seems you have an issue with Easy Anti-Cheat, which can indicate some specific issues on your PC. We suggest you to check following article on Easy Anti-Cheat support page.

    Let us know if that helped.
  • Hello again.

    Even if it didn't help last time i tried it, in this instance checking my files in Steam fixed all the issues. Steam found 4 broken files.
Sign In or Register to comment.